T9 gaming keybad not working properly  

  RSS

0

So, the first time i plugged this keypad in it worked just fine. I then installed the driver software and restarted my computer. After i restarted my computer it now fails to recognize any keystrokes from the keypad. It lights up when i plug it in, my computer plays the sound effect acknowledging something was plugged in when i plug it in. However, when i press keys on the keypad,...nothing. I've tried numerous common troubleshooting fixes for hardware issues. Restarted computer with and without it plugged in, removed the software and tried, re-installed the software and tried. Open to suggestions at this point.

 
0

Got it to work, heres how i fixed it. I ended up wiping my hard drive and re-installing the windows OS. After re-intalling the OS i did "NOT" install the driver software. it is now working just fine. Luckily, i only use this laptop for LoL and so i had no data loss from re-installing OS. This may not be an option for some folks. I can't explain the logistics of why this fixed it, i imagine something became bugged when i installed the driver. Something at the kernel level and removing/re-installing the driver wasn't enough to debug it. I had something similar happen years ago with an external cd-rom drive so i figured it was worth a shot and it worked..

I am having the same problem, but I'm not in a position to wipe my hard drive. Does anyone know why the driver software ruins the keypad? And how can I fix this?

Share: